wikiroute

networking recipes

User Tools

Site Tools


ipv6_tunnel_at_home

This is an old revision of the document!


Start by configuring the Ethernet and the WLAN interfaces on the MR3020 in two different networks:

/etc/config/network
config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'
 
config interface 'wan'
	option ifname 'eth0'
	option proto 'static'
	option ipaddr '192.168.1.66'
	option netmask '255.255.255.0'
	option gateway '192.168.1.1'
	option dns '8.8.8.8'
 
config interface 'wifi'
        option proto 'static'
        option ipaddr '192.168.66.1'
        option netmask '255.255.255.0'
        option ip6addr '2a01:240:fe00:80ab::1/64'
/etc/config/dhcp
config dnsmasq
	option domainneeded	1
	option boguspriv	1
	option filterwin2k	0  # enable for dial on demand
	option localise_queries	1
	option rebind_protection 1  # disable if upstream must serve RFC1918 addresses
	option rebind_localhost 1  # enable for RBL checking and similar services
	#list rebind_domain example.lan  # whitelist RFC1918 responses for domains
	option local	'/lan/'
	option domain	'lan'
	option expandhosts	1
	option nonegcache	0
	option authoritative	1
	option readethers	1
	option leasefile	'/tmp/dhcp.leases'
	option resolvfile	'/tmp/resolv.conf.auto'
	#list server		'/mycompany.local/1.2.3.4'
	#option nonwildcard	1
	#list interface		br-lan
	#list notinterface	lo
	#list bogusnxdomain     '64.94.110.11'
 
config dhcp wifi
	option interface	wifi
	option start 	100
	option limit	150
	option leasetime	12h
 
config dhcp wan
	option interface	wan
	option ignore	1
/etc/config/wireless
config wifi-device  radio0
	option type     mac80211
	option channel  11
	option macaddr	f8:d1:11:bd:62:ce
	option hwmode	11ng
	option htmode	HT20
	list ht_capab	SHORT-GI-20
	list ht_capab	SHORT-GI-40
	list ht_capab	RX-STBC1
	list ht_capab	DSSS_CCK-40
 
config wifi-iface
	option device   radio0
	option network  wifi
	option mode     ap
	option ssid 'PocketBox'
        option encryption 'psk2'
        option key '1CAFE2DECA'
/etc/config/firewall
config zone
	option name             wifi
	option input            ACCEPT
	option output           ACCEPT
	option forward          REJECT
 
config zone
	option name		lan
	option network		'lan'
	option input		ACCEPT
	option output		ACCEPT
	option forward		REJECT
 
config zone
	option name		wan
	option network		'wan'
	option input		REJECT
	option output		ACCEPT
	option forward		REJECT
	option masq		1
	option mtu_fix		1
 
config forwarding
	option src		lan
	option dest		wan
 
config forwarding
        option src              wifi
        option dest             wan
ipv6_tunnel_at_home.1428157973.txt.gz · Last modified: 2015/04/04 16:32 by samer