brctl addbr br-clab
brctl addif br-clab eth0
ip link set dev br-clab up
containerlab deploy -t frr02.clab.yml
docker exec -it clab-frr02-router1 vtysh
name: frr02
topology:
nodes:
router1:
kind: linux
image: frrouting/frr:v7.5.1
binds:
- router1/daemons:/etc/frr/daemons
- router1/frr.conf:/etc/frr/frr.conf
router2:
kind: linux
image: frrouting/frr:v7.5.1
binds:
- router2/daemons:/etc/frr/daemons
- router2/frr.conf:/etc/frr/frr.conf
router3:
kind: linux
image: frrouting/frr:v7.5.1
binds:
- router3/daemons:/etc/frr/daemons
- router3/frr.conf:/etc/frr/frr.conf
br-clab:
kind: bridge
links:
- endpoints: ["router1:eth1", "router2:eth1"]
- endpoints: ["router1:eth2", "router3:eth1"]
- endpoints: ["router2:eth2", "router3:eth2"]
- endpoints: ["br-clab:eth1", "router1:eth3"]
frr version 7.5.1_git
frr defaults traditional
hostname router1
no ipv6 forwarding
!
interface eth1
ip address 192.168.1.1/24
!
interface eth2
ip address 192.168.2.1/24
!
interface eth3
ip address 172.18.100.254/16
!
interface lo
ip address 10.10.10.1/32
!
router ospf
network 192.168.1.0/24 area 0.0.0.0
network 192.168.2.0/24 area 0.0.0.0
network 172.18.0.0/16 area 0.0.0.0
!
line vty
!